"Cannot GET /callback" error with AUTH0


#1

How to remove ’#!’ from url?


#2

Hi, thanks for your topic!

  1. Replace $locationProvider.hashPrefix('!'); from app.js to $locationProvider.html5Mode(true);
  2. Add <base href="/"> in index.html before </head>

Let me know if this solution solves your problem :slight_smile:


#3

i have done it earlier… now affect… changet callback url … now affect… again… again…:face_with_symbols_over_mouth:
It WORKS!!!:grin:


#4

Didn’t understand, now it works?
This solution works for you?


#5

Problem was: emailbuilder uses ngRoute, Auth0 uses uiroute — mismatch in settings.

work config:

$locationProvider.hashPrefix(’’);
html5 — OFF

callback replaced from “hostURL:port/callback” to “hostURL:port/#/callback”

P.S. turning html5 ON just hides hashtag from URL shown in brouser not from real path - so it does not work for me


#6

Oh, thank you for your solution!
In Javascript you can manipulate only with pushState, but you can configure your server side to return all requests to index.html, look at this article: http://www.codelord.net/2015/05/12/angularjs-how-to-setup-pushstate-with-html5mode/